New release (v0.11.0) – please update!

Dear Users – it’s been a while since I last posted (been rather busy, both in day job and in mining) – and even for this one I’ll keep it short (tons of things to write about, but not enough time right now). For now, I’ll only post this little update and request.

New Release – v0.11.0

After a ton of work I’ve finally put live the latest release (v0.11.0), that contains an equal ton of updates, bugfixes, improvements, etc – I’ll write a bit more about that later, when I’ve also updated the new lukSticks (that will have an equally long list of fixes and improvements…); but the latter will take a little bit longer because I want to run just a few more burn-in tests.

Though the lukSticks are still copying, the miner release itself is already live, at the usual place (http://www.lukminer.net/releases).

To everybody that mines Heavy : Please update ASAP

If you’re mining cryptonight heavy, chances are you’ve seen – or at least heard about – the blow-up of sumokoin. I still don’t completely get who are the good guys and who are the bad guys; but at the end of the day, that’s neither here nor there – the bottom line is that after a long of what looks like a civil war in this coin, the Sumo community has decided to go back from cryptonight heavy to the original, old, cryptonight classic.

Now if you like this (I certainly don’t!) you can still mine sumo with the “-a xnclassic” flag – but since Sumo will now be ASIC-mineable whatever you’re going to put to it with lukMiner probably won’t make a dent. Maybe at least for Sumo that change is for the better – who knows – and if it does prosper this way then I’ll wish it all the best (I still have a lot of currently locked coins, so won’t complain) …. but bottom line, that coin is now no longer of interest to me.

All that said, the real problem is that v0.10.7 actually diverted all developer shares to a sumo pool – but with sumo having just changed back to xnclassic those hashes will no longer be valid, so chances are your miner will stop working. If you were mining sumo to start with you’ll already have found that out; but if you’re mining another ‘heavy’ coin (I’m currently going Loki and Saronite) then you’ll probably run into this trap: The miner itself will still be able to mine Loki and Saronite – but since the devShares won’t work it’ll likely die, anyway. As such: If you are mining any heavy coins, please update to 0.11.0 immediately.

I’ll send a few more updates later, but at least for now that’ll have to be it.

With that…. Happy Mining!

 

Published by

lukMiner

To learn more about me, look at the "About" page on http://lukminer.org

13 thoughts on “New release (v0.11.0) – please update!”

  1. Thanks, I just noticed my rigs were getting stuck and wondered if you fixed it. Great timing and thanks again for all the hard work.

    Like

    1. Absolutely correct, that’s how I updated in the past. Only one “correction”: For those users that have _bootable_ phi machines – asrock, exxact, colfax, or neon miner – you have(!) to use the “cpu-phi” version of the lukstick, _not_ the “mpss-knl” one – the latter is only for rigs with KNL _pci cards_ (7220A, 7240P etc).

      Also, there’s a new lukStick out (v3.1, see releases page) that’ll fix a ton of other stuff, too.

      Like

  2. Hi luk.

    Where can I find source code for the lukMiner? I do not care if you hardcoded 1% donation to your wallet or not, but in case you disappear, and there is another XMR fork, I would like to be able to update mining algorithms myself relatively easily / quickly. Or contribute some optimizations back.

    Thanks! 🙂

    Like

    1. Source code isn’t public, because if it was all the “big” miners would just incorporate it, and I’d not see a dime, ever :-/

      I do promise, though, that if I ever do get out of mining I will release it publicly; I’m a big fan of open source myself (all my other code is open), so can do that in five minutes – and I’d rather see my code be used for free than disappear completely, too!

      Like

  3. Finally got my Asrock rack 4×7210 machine and wanted to test out your new luksticks. Just realized you swapped out CentOS to Ubuntu 16.04. That alone obviously signifies that you did a ton of work on it since I’m sure a lot of Intel’s MPSS software was built with Redhat/CentOS in mind. That also makes it easier if you want to throw a GPU in there since you don’t have to recompile all the usual mining software from scratch.

    Thanks for continuing to update your software.

    Like

    1. Yeah, I prefer Ubuntu, so use it when I can. The mpss lukstick requires centos (and even a very specific version for that), but for the non mpss one Ubuntu works just fine.

      Like

      1. Oh gotcha, dumb comment then. I didn’t realize the cpu version of the lukstick was likely always using Ubuntu. I never tried it before today and assumed they were all using the same OS.

        Like

      2. Ubuntu seems to have slightly higher hash rate; there’s a few comment threads on that (either here and/or on reddit) on that. Nobody knows why – “should” be the same kernel – but that’s what the numbers show. So I’d be using ubuntu on the host CPUs even if I _didn’t_ prefer it :-).

        For the cards it doesn’t matter, becaues these basically run their own OS, anyway (so what runs on the host doesn’t matter much). Also funny that the cards get somewhat higher hash rate than the host CPUs, even though in theory they should be the same …. .

        Like

  4. Just one more comment for now. Seems like you disabled ssh password auth as I was having trouble ssh’ing in. Checking /etc/ssh/sshd_config confirms that to be the case. So I scp’ed over the private key file in /root/.ssh/lukStick_ecdsa file over to my laptop so I can use private key auth. Don’t forget to set something like chmod 0400 on it, othewise ssh will complain. Just an fyi in case someone else runs into the same issue.

    Like

  5. Sigh. “Disabled” is not exactly the right word for that – “broke” probably fits it better. I did copy the keys over, and in the very last minute even thought of installing openssh (becasue for some reason, ubuntu by default doesn’t install it), and even made sure that root can actually log in (which ubuntu also doesn’t allow by default)…. but seems I must have forgotten something else that’s required for remote root login. I’ll track it down for stick version 3.2 😦

    Like

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out /  Change )

Google+ photo

You are commenting using your Google+ account. Log Out /  Change )

Twitter picture

You are commenting using your Twitter account. Log Out /  Change )

Facebook photo

You are commenting using your Facebook account. Log Out /  Change )

Connecting to %s