Phis, H110 Pro BTC+ boards, and risers …

Aaaand – another big shout-out for one of my readers: “somebody” (and I can’t for the life of me find the comment to figure out who it was…) recently mentioned he’d gotten his Phi card to work in an Asrock H110 Pro BTC+ board, and with a riser to boot … and since in my last post re the Z170A desktop boards I had explicitly mentioned that I had unsuccessfully tried both this board and some PCIe riser cables (also in the Z170 boards) I at first found this a bit incredible. However, he also sent me a picture, so apparently I must have done something wrong last week, and decided to re-do that experiment… and lo and behold, it does indeed work…. Hm. Oh well.

First, I looked up what I had actually written about the H110BTC board – and turns out I had never actually said that it didn’t work with the cards, I had only said it didn’t boot, and that I suspected that it was DoA – but after re-assembling it again it actually booted up just fine. Maybe I didn’t have the board’s external power connectors in correctly last week (the H110’s have these weird external SATA power cable connectors to power the PCIe slots), or maybe I had simply forgotten to put in the memory (not the first time – I keep forgetting that non-Phi CPUs do need memory :-/), but either way, the board without any cards booted up just fine.

Second, I dug out my PCI1 1x-to-16x riser cables I had recently gotten on ebay, hooked it up to a 7220A card, plugged in a lukStick, and indeed, it booted up just fine. First time the system didn’t properly boot the card (0xff mic status in the dmesg, and “error” status in “micctrl -s”), but by that time the card had already shown up on the PCI bus (“lspci | grep Device”), the kernel module has already loaded, and “micctrl” already showed that there was a card in the system – so that was a good sign. Rebooted again, went into the BIOS, and changed a few settings – in particular, I set the PCIe speeds from “auto” to the highest the boards offerened (Gen2 for some, Gen3 for others!?), and forced primary graphics to “on board” (above 4GB decoding was already on), and rebooted … and la-voila, it booted up like a charm, with riser cable that I had claimed wouldn’t work with those cards, and everything. Duh. Either way, here two pics of the “final” rig – maybe not the most professional rig, but all I could do between “getting up” and “getting my coffee”….

Bottom line: Unlike what I may have said in previous articles and replies to comments: The H110 Pro BTC+ board apparently does work with the 7220A card (at least, with one – I haven’t tried more, yet), and the 7220A works with PCIe 1x-to-16x risers (at least in this board – haven’t tried in other boards, yet).

With that – happy mining…


PS: Of course, the main reason for using riser cables is to use more than one card, which I haven’t tested yet. I’ll post info on that as soon as I find the time to run that.

Published by


To learn more about me, look at the "About" page on

16 thoughts on “Phis, H110 Pro BTC+ boards, and risers …”

  1. I did mention to you that the cards worked with PCIe risers, I used a ASRock x99 with 5110 and 7120’s. This was back in January.


    1. Good question.
      Short answer is – certainly not _12_ cards, because the drivers will do only 8 cards IIUC. I do have the source for the drivers, so this _might_ be fixable, but I’m not actually too keen on starting the work on abandoned drivers, so at least right now, a maximum of 8 it is.

      The more interesting question is whether it’d work with _8_ cards, and that I don’t yet have an answer to. I did quickly put in a second card, and booted the machine – and indeed, it _does_ show a second card on the pci bus (lspci), which is good news (because the z170 boards don’t even show the card) – but then, when it tries to load the module it sais something about conflicts with mapping memory. Not sure if I simply have too few memory in that machine (just barely eonugh to boot), or if there’s something more sinister going on … just didn’t ahve time to look at it, yet.

      I do know some users have experimented with such setups, so maybe somebody else has an answer? If so, chime in – i’ll certainly approve any comments on that!


  2. Haven’t tried it with the new lukstick version, but were you able to set it up to recognize the ethernet port or do I need to stick with the roundabout way that I did it?


  3. If I have a chance to pickup one of these 7220A, 7220P or 7240P cards what are they worth? Anyone have any mining results on CN7 or CN7 lite?


    1. For 7220A I am averaging about 3 khs Cn7 and CN heavy, haven’t used the lite versions. On alloy I got 1.55 khs or so. I am not sure about any of the others as I haven’t ventured, seeing as heavy and v7 have for the most part have been the most profitable

      PS: Huge fan of your swimming. (yes, I know its phelps, couldn’t resist and I am sure you get it all the time too)


    1. Yes they do, but since there is an issue with the ethernet support on it, it made it very difficult back then when I did it, and now since you have to have a certain setup of the linux kernel, it may take a lot of back and forth to get it to work. You can do it, but I wouldn’t recommend it. Besides, I don’t think it would be worth it because all the major coins have or will be moving from the algos still available through the miner for those cards.


      1. Not he said x100, not x200. Apart from that, for machines with broken/unsupported/flaky ethernet connections I’ve sometimes successfully used some USB wireless dongles – you can get those for ~$5, and since you dont’ need much bandwidth they should do. Problem of course is that the x100s need a pretty old centos kernel, and I don’t know which ones are supported on that kernel…


      2. I was able to get it to work on an H110 but not the + as I never had one… You can really only post one at a time on it anyways. I have fried the motherboard since due to buying a refurbished power supply, but it was after I got the other board instead for ease of use. I can probably dig up the old photos and send them to you. I know I was going back and forth with Luk Ad nauseum and feel awful for that, but it did work. I just really wouldn’t recommend it at this point. The X200s are barely scraping by, the X100s well….


      3. I bought btc+ yesterday and it also not detect x100 😥 I’m starting to think that my 31s1p from taobao is not working…


      4. 4Gb decoding is enabled, lspci on Debian 9.4 and Ubuntu 18.04 LiveCD show nothing good.
        PCIe slot empty in bios, coprocessor heats up and blinking blue light 8Hz (of course I’m cooling it).


  4. Anyway I have one 31S1P card and now I must test it 🙂 Asus Z270-A Prime and Z370-A Prime not detect her.

    I will try to find motherboards you tested:

    ASUS Z170 Pro Gaming Aura, with a G3930 “Kaby Lake” Celeron (2 cores, 2.9GHz, 4MB L3 cache)
    MSI Z170A PCMate, with a G3930.
    MSI Z170A Gaming M5, with a G3920 Kaby Lake (only 3MB cache)
    MSI Z170A Krait Gaming, again with a 3930.

    These motherboards work with x100, true?

    Thanks for reply.


Leave a Reply

Fill in your details below or click an icon to log in: Logo

You are commenting using your account. Log Out /  Change )

Facebook photo

You are commenting using your Facebook account. Log Out /  Change )

Connecting to %s